부분합
시간 제한 | 메모리 제한 | 제출 | 정답 | 맞은 사람 | 정답 비율 |
---|---|---|---|---|---|
0.5 초 (하단 참고) | 128 MB | 26508 | 6803 | 4843 | 25.609% |
문제
10,000 이하의 자연수로 이루어진 길이 N짜리 수열이 주어진다. 이 수열에서 연속된 수들의 부분합 중에 그 합이 S 이상이 되는 것 중, 가장 짧은 것의 길이를 구하는 프로그램을 작성하시오.
입력
첫째 줄에 N (10 ≤ N < 100,000)과 S (0 < S ≤ 100,000,000)가 주어진다. 둘째 줄에는 수열이 주어진다. 수열의 각 원소는 공백으로 구분되어져 있으며, 10,000이하의 자연수이다.
출력
첫째 줄에 구하고자 하는 최소의 길이를 출력한다. 만일 그러한 합을 만드는 것이 불가능하다면 0을 출력하면 된다.
예제 입력 1 복사
xxxxxxxxxx
10 15
5 1 3 5 10 7 4 9 2 8
예제 출력 1 복사
xxxxxxxxxx
2
풀이
n이 100,000이니 O(N)으로 풀어야 하는 문제입니다.
투포인터 알고리즘을 이용해서 풀이했습니다.
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
String [] t = br.readLine().split(" ");
int n = Integer.parseInt(t[0]);
int m = Integer.parseInt(t[1]);
int arr[] = new int[n];
t = br.readLine().split(" ");
for(int i=0; i<n; i++) {
arr[i] = Integer.parseInt(t[i]);
}
int start = 0;
int end = 0;
int sum = 0;
int min = Integer.MAX_VALUE;
while(true) {
if(sum>=m) {
min = Math.min(min, end-start);
sum-=arr[start++];
}
else {
if(end>=n) {
break;
}
sum+=arr[end++];
}
}
if(min == Integer.MAX_VALUE) {
System.out.println(0);
}
else {
System.out.println(min);
}
}
}
'알고리즘' 카테고리의 다른 글
[백준 1238] 파티 - JAVA //le_effort (0) | 2021.04.06 |
---|---|
[백준 11728] 배열 합치기 - JAVA // le_effort (0) | 2021.04.06 |
[백준 11967] 불켜기 - JAVA //le_effort (0) | 2021.04.02 |
[백준 1043] 거짓말 - JAVA //le_effort (0) | 2021.04.02 |
[2021 KAKAO BLIND RECRUITMENT] 합승 택시 요금 - JAVA //le_effort (0) | 2021.04.01 |