파티
시간 제한 | 메모리 제한 | 제출 | 정답 | 맞은 사람 | 정답 비율 |
---|---|---|---|---|---|
1 초 | 128 MB | 17115 | 8007 | 5269 | 45.185% |
문제
N개의 숫자로 구분된 각각의 마을에 한 명의 학생이 살고 있다.
어느 날 이 N명의 학생이 X (1 ≤ X ≤ N)번 마을에 모여서 파티를 벌이기로 했다. 이 마을 사이에는 총 M개의 단방향 도로들이 있고 i번째 길을 지나는데 Ti(1 ≤ Ti ≤ 100)의 시간을 소비한다.
각각의 학생들은 파티에 참석하기 위해 걸어가서 다시 그들의 마을로 돌아와야 한다. 하지만 이 학생들은 워낙 게을러서 최단 시간에 오고 가기를 원한다.
이 도로들은 단방향이기 때문에 아마 그들이 오고 가는 길이 다를지도 모른다. N명의 학생들 중 오고 가는데 가장 많은 시간을 소비하는 학생은 누구일지 구하여라.
입력
첫째 줄에 N(1 ≤ N ≤ 1,000), M(1 ≤ M ≤ 10,000), X가 공백으로 구분되어 입력된다. 두 번째 줄부터 M+1번째 줄까지 i번째 도로의 시작점, 끝점, 그리고 이 도로를 지나는데 필요한 소요시간 Ti가 들어온다. 시작점과 끝점이 같은 도로는 없으며, 시작점과 한 도시 A에서 다른 도시 B로 가는 도로의 개수는 최대 1개이다.
모든 학생들은 집에서 X에 갈수 있고, X에서 집으로 돌아올 수 있는 데이터만 입력으로 주어진다.
출력
첫 번째 줄에 N명의 학생들 중 오고 가는데 가장 오래 걸리는 학생의 소요시간을 출력한다.
예제 입력 1 복사
xxxxxxxxxx
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
예제 출력 1 복사
xxxxxxxxxx
10
풀이
다익스트라 알고리즘을 이용해서 풀이를 했습니다.
xxxxxxxxxx
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;
public class Main {
static int n,m,x;
static ArrayList<Node>list[];
static int dist[][];
public static void main(String[] args) throws IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
String [] t = br.readLine().split(" ");
n = Integer.parseInt(t[0]);
m = Integer.parseInt(t[1]);
x = Integer.parseInt(t[2]);
dist = new int[n+1][n+1];
list = new ArrayList[n+1];
for(int i=1; i<=n; i++) {
list[i] = new ArrayList<>();
}
for(int i=1; i<=n; i++) {
Arrays.fill(dist[i], 987654321);
}
for(int i=0; i<m; i++) {
t = br.readLine().split(" ");
int start = Integer.parseInt(t[0]);
int end = Integer.parseInt(t[1]);
int w = Integer.parseInt(t[2]);
list[start].add(new Node(end,w));
}
for(int i=1; i<=n; i++) {
djistra(i);
}
int max = 0;
for(int i=1; i<=n; i++) {
max = Math.max(max, dist[i][x]+dist[x][i]);
}
System.out.println(max);
}
public static void djistra(int start) {
PriorityQueue<Node>pq = new PriorityQueue<>();
boolean visited [] = new boolean[n+1];
pq.add(new Node(start,0));
dist[start][start] = 0;
while(!pq.isEmpty()) {
Node a = pq.poll(); // 시작 도시와 연결된 도시
visited[a.city] = true;
for(Node tmp : list[a.city]) {
if(visited[tmp.city]) continue;
if(dist[start][tmp.city] > dist[start][a.city]+tmp.w) {
dist[start][tmp.city] = dist[start][a.city]+tmp.w;
pq.add(new Node(tmp.city,dist[start][tmp.city]));
}
}
}
}
}
class Node implements Comparable<Node>{
int city,w;
Node(int city, int w){
this.city = city;
this.w = w;
}
public int compareTo(Node o) {
return this.w - o.w;
}
}
'알고리즘' 카테고리의 다른 글
[백준 2138] 전구와 스위치 - JAVA // le_effort (0) | 2021.04.22 |
---|---|
[백준 1644] 소수의 연속합 - JAVA // le_effort (0) | 2021.04.06 |
[백준 11728] 배열 합치기 - JAVA // le_effort (0) | 2021.04.06 |
[백준 1806] 부분합 - JAVA // le_effort (0) | 2021.04.04 |
[백준 11967] 불켜기 - JAVA //le_effort (0) | 2021.04.02 |