최소비용 구하기
시간 제한 | 메모리 제한 | 제출 | 정답 | 맞은 사람 | 정답 비율 |
---|---|---|---|---|---|
0.5 초 | 128 MB | 32198 | 11051 | 6532 | 33.712% |
문제
N개의 도시가 있다. 그리고 한 도시에서 출발하여 다른 도시에 도착하는 M개의 버스가 있다. 우리는 A번째 도시에서 B번째 도시까지 가는데 드는 버스 비용을 최소화 시키려고 한다. A번째 도시에서 B번째 도시까지 가는데 드는 최소비용을 출력하여라. 도시의 번호는 1부터 N까지이다.
입력
첫째 줄에 도시의 개수 N(1 ≤ N ≤ 1,000)이 주어지고 둘째 줄에는 버스의 개수 M(1 ≤ M ≤ 100,000)이 주어진다. 그리고 셋째 줄부터 M+2줄까지 다음과 같은 버스의 정보가 주어진다. 먼저 처음에는 그 버스의 출발 도시의 번호가 주어진다. 그리고 그 다음에는 도착지의 도시 번호가 주어지고 또 그 버스 비용이 주어진다. 버스 비용은 0보다 크거나 같고, 100,000보다 작은 정수이다.
그리고 M+3째 줄에는 우리가 구하고자 하는 구간 출발점의 도시번호와 도착점의 도시번호가 주어진다. 출발점에서 도착점을 갈 수 있는 경우만 입력으로 주어진다.
출력
첫째 줄에 출발 도시에서 도착 도시까지 가는데 드는 최소 비용을 출력한다.
예제 입력 1 복사
xxxxxxxxxx
5
8
1 2 2
1 3 3
1 4 1
1 5 10
2 4 2
3 4 1
3 5 1
4 5 3
1 5
예제 출력 1 복사
xxxxxxxxxx
4
풀이
다익스트라로 풀 수 있는 문제였습니다.
어떻게 다익스트라인지 알 수 있느냐 하면 출발도시와, 도착도시가 주어졌고
문제의 인풋에서 도착도시가 어떤 도시일지, 출발도시가 어디일지 각 테스트 케이스 마다 다르게 주어지니,
한 정점에서 다른 정점까지의 모든 거리를 구하는 알고리즘인 다익스트라 알고리즘으로 해결 해야 겠다 라는 생각이 들었습니다.
코드
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.*;
public class Main {
static int n,m;
static ArrayList<Node>[] list;
static int dist[];
static boolean visited[];
public static void main(String[] args) throws NumberFormatException, IOException {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
n = Integer.parseInt(br.readLine()); // 도시수
m = Integer.parseInt(br.readLine()); // 버스 수
list = new ArrayList[n+1];
visited = new boolean[n+1];
dist = new int[n+1];
for(int i=1; i<=n; i++) {
list[i] = new ArrayList<>();
}
for(int i=0; i<m; i++) {
String [] t = br.readLine().split(" ");
int start = Integer.parseInt(t[0]);
int end = Integer.parseInt(t[1]);
int w = Integer.parseInt(t[2]);
list[start].add(new Node(end,w));
}
String [] t = br.readLine().split(" ");
int start_city = Integer.parseInt(t[0]);
int end_city = Integer.parseInt(t[1]);
djistra(start_city);
System.out.println(dist[end_city]);
}
public static void djistra(int start_city) {
PriorityQueue<Node>pq = new PriorityQueue<>();
pq.add(new Node(start_city,0));
Arrays.fill(dist, Integer.MAX_VALUE);
dist[start_city] = 0;
while(!pq.isEmpty()) {
Node poll = pq.poll();
visited[poll.city] = true;
for(Node a: list[poll.city]) {
if(visited[a.city]) {
continue;
}
if(dist[a.city] > dist[poll.city]+a.w) {
dist[a.city] = dist[poll.city]+a.w;
pq.add(new Node(a.city,dist[a.city]));
}
}
}
}
}
class Node implements Comparable<Node>{
int city,w;
Node(int city ,int w){
this.city = city;
this.w=w;
}
public int compareTo(Node o) {
return this.w-o.w;
}
}
'알고리즘' 카테고리의 다른 글
[백준 1764] 듣보잡 - JAVA // le_effort (0) | 2021.03.02 |
---|---|
[2021 KAKAO BLIND RECRUITMENT신규 아이디 추천] (0) | 2021.02.25 |
[백준 1654] 랜선 자르기 - JAVA //le_effort (0) | 2021.02.25 |
[백준 2805] 나무 자르기 -JAVA // le_effort (0) | 2021.02.23 |
[백준 1920] 수 찾기 - JAVA //le_effort (0) | 2021.02.23 |